Are You Getting The Server Version Mismatch Error In Phasmophobia?

1 min


Are You Getting The Server Version Mismatch Error In Phasmophobia
Are You Getting The Server Version Mismatch Error In Phasmophobia

There’s nothing more frustrating than wanting to play with friends and getting that pesky “server version mismatch error” in Phasmophobia. The game already has some lobby issues the developer is trying to work out, but it can be frustrating when you installed the game to play with friends, only to get an error when you put in a private code.

What Is The Server Version  Mismatch Error In Phasmophobia?

The server mismatch error usually comes up when you don’t have the same region selected as the server you’re trying to join.

  • If your region is set to the US and you’re trying to join a game hosted from the EU, you will get the server mismatch error.
  • This means you will have to connect to the region of the person you’re trying to play with.

But how do you connect to a different region in Phasmophobia?

How Do Fix The Server Version Mismatch Error In Phasmophobia?

The developer gave a checklist of things to try if you get the server version mismatch error:

1. Make sure you have the same region selected as the player you are attempting to connect to

2. Try switching the region (e.g., if your region is set to the US, try changing to EU or SA)

3. Ensure you both have the same game version installed (bottom left of main menu whiteboard)

4. Ensure you are both on either Beta or Stable (as these two don’t connect to each other)

5. Try launching the tutorial and leave it once the game loads, then try to connect to your friend again

6. Restart your game

Let us know if that fixed the issue for you.

Phasmophobia Frequently Asked Questions


Like it? Share with your friends!

Bryan Havoc

I cover console video games like Crossfire, Minecraft, Apex Legends, Counter-Strike, Valorant, PUBG, Grand Theft Auto V, Destiny 2, Phasmophobia and everything in between.